RubyGems Navigation menu

http 5.2.0

An easy-to-use client library for making requests from Ruby. It uses a simple method chaining system for building requests, similar to Python's Requests.

Gemfile:
= Copy to clipboard Copied!

install:
=

Versions:

  1. 5.2.0 - February 05, 2024 (83.5 KB)
  2. 5.1.1 - December 17, 2022 (81 KB)
  3. 5.1.0 - June 17, 2022 (80 KB)
  4. 5.0.4 - October 07, 2021 (78.5 KB)
  5. 5.0.3 - October 06, 2021 (78.5 KB)
Show all versions (103 total)

Runtime Dependencies (5):

addressable ~> 2.8
base64 ~> 0.1
http-cookie ~> 1.0
llhttp-ffi ~> 0.5.0

Development Dependencies (1):

bundler ~> 2.0

Owners:

Pushed by:

Authors:

  • Tony Arcieri, Erik Michaels-Ober, Alexey V. Zapparov, Zachary Anker

SHA 256 checksum:

b99ed3c65376e0fd8107647fbaf5a8ab4f66c347d1271fb74cea757e209c6115

Total downloads 133,770,427

For this version 2,066,839

License:

MIT

Required Ruby Version: >= 2.6

New versions require MFA: true

Version published with MFA: true

Links: