RubyGems Navigation menu

commander 5.0.0

The complete solution for Ruby command-line executables. Commander bridges the gap between other terminal related libraries you know and love (OptionParser, HighLine), while providing many new features, and an elegant API.

Gemfile:
= Copier Copié!

installation:
=

Versions:

  1. 5.0.0 - January 15, 2024 (37,5 ko)
  2. 4.6.0 - April 09, 2021 (37,5 ko)
  3. 4.5.2 - March 12, 2020 (37 ko)
  4. 4.5.1 - March 08, 2020 (37 ko)
  5. 4.5.0 - January 21, 2020 (36,5 ko)
Voir toutes les versions (40)

Dépendances de Runtime (1):

highline ~> 3.0.0

Dépendances de Development (4):

rake >= 0
rspec ~> 3.2
rubocop ~> 1.12.1
simplecov >= 0

Propriétaires:

Pushed by:

Auteurs:

  • TJ Holowaychuk, Gabriel Gilder

Total de contrôle SHA 256:

= Copier Copié!

Total de téléchargements 79 527 940

Pour cette version 65 498

License:

MIT

Version de Ruby requise: >= 3.0

Liens: