RubyGems Navigation menu

glimmer-dsl-libui 0.12.2

Glimmer DSL for LibUI (Fukuoka Award Winning Prerequisite-Free Ruby Desktop Development Cross-Platform Native GUI Library) - Winner of Fukuoka Ruby Award Competition 2022 Special Award (http://www.digitalfukuoka.jp/topics/187?locale=ja) - No need to pre-install any prerequisites. Just install the gem and have cross-platform native GUI that just works on Mac, Windows, and Linux! Glimmer DSL for LibUI aims to provide declarative DSL syntax that visually maps to GUI control hierarchy, convention over configuration via smart defaults, automation of low-level details, requiring the least amount of syntax possible to build GUI, bidirectional data-binding, custom control/window support, and application/gem/window/control scaffolding. If you liked Shoes, You'll love Glimmer!

Gemfile:
= Copy to clipboard Copied!

install:
=

Versions:

  1. 0.12.2 - July 14, 2024 (374 KB)
  2. 0.12.1 - June 24, 2024 (369 KB)
  3. 0.12.0 - June 22, 2024 (368 KB)
  4. 0.11.10 - June 22, 2024 (367 KB)
  5. 0.11.9 - June 21, 2024 (367 KB)
Show all versions (161 total)

Runtime Dependencies (13):

chunky_png ~> 1.4.0
color ~> 1.8
equalizer = 0.0.11
glimmer ~> 2.7.9
libui = 0.1.2.pre
os >= 1.0.0, < 2.0.0
perfect-shape ~> 1.0.8
puts_debuggerer >= 1.0.1, < 2.0.0
rake >= 10.1.0, < 14.0.0
rake-tui >= 0.2.3, < 2.0.0
rouge >= 3.26.0, < 4.0.0
super_module ~> 1.4.1
text-table >= 1.2.4, < 2.0.0

Development Dependencies (8):

coveralls = 0.8.23
json = 2.6.1
juwelier >= 2.4.9, < 3.0.0
psych = 4.0.3
rspec ~> 3.0
simplecov ~> 0.16.1
simplecov-lcov ~> 0.7.0
stringio = 3.0.1

Owners:

Pushed by:

Authors:

  • Andy Maleh

SHA 256 checksum:

= Copy to clipboard Copied!

Total downloads 157,816

For this version 182

License:

MIT

Required Ruby Version: >= 0

Links: