RubyGems Navigation menu

rubocop 1.17.0

RuboCop is a Ruby code style checking and code formatting tool. It aims to enforce the community-driven Ruby Style Guide.

Gemfile:
= Copy to clipboard Copied!

install:
=

Versions:

  1. 1.63.2 - April 16, 2024 (623 KB)
  2. 1.63.1 - April 10, 2024 (623 KB)
  3. 1.63.0 - April 08, 2024 (623 KB)
  4. 1.62.1 - March 11, 2024 (619 KB)
  5. 1.62.0 - March 06, 2024 (618 KB)
  6. 1.17.0 - June 15, 2021 (483 KB)
Show all versions (268 total)

Runtime Dependencies (8):

parallel ~> 1.10
parser >= 3.0.0.0
rainbow >= 2.2.2, < 4.0
regexp_parser >= 1.8, < 3.0
rexml >= 0
rubocop-ast >= 1.7.0, < 2.0
unicode-display_width >= 1.4.0, < 3.0

Development Dependencies (1):

bundler >= 1.15.0, < 3.0

Owners:

Pushed by:

Authors:

  • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

SHA 256 checksum:

e69e12da57c04241dd7978b43e570e1eed589d486271842b10d9c921a330d052

Total downloads 411,649,698

For this version 1,444,621

License:

MIT

Required Ruby Version: >= 2.5.0

New versions require MFA: true

Links: