RubyGems Navigation menu

rubocop 1.26.1

RuboCop is a Ruby code style checking and code formatting tool. It aims to enforce the community-driven Ruby Style Guide.

Gemfile:
= Copy to clipboard Copied!

instalar:
=

Versões:

  1. 1.64.0 - May 23, 2024 (626 KB)
  2. 1.63.5 - May 09, 2024 (623 KB)
  3. 1.63.4 - April 28, 2024 (623 KB)
  4. 1.63.3 - April 22, 2024 (623 KB)
  5. 1.63.2 - April 16, 2024 (623 KB)
  6. 1.26.1 - March 22, 2022 (519 KB)
Mostrar todas as versões (272)

Runtime Dependencies (8):

parallel ~> 1.10
parser >= 3.1.0.0
rainbow >= 2.2.2, < 4.0
regexp_parser >= 1.8, < 3.0
rexml >= 0
rubocop-ast >= 1.16.0, < 2.0
unicode-display_width >= 1.4.0, < 3.0

Development Dependencies (1):

bundler >= 1.15.0, < 3.0

Donos:

Pushed by:

Autores:

  • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

SHA 256 checksum:

f4c91b087a10596529fb82146f214824f952e6b2e15977002df54a85b32f2018

Total de downloads 422.436.754

Desta versão 3.201.101

Licença:

MIT

Versão Requerida do Ruby: >= 2.5.0

New versions require MFA: true

Version published with MFA: true

Links: