RubyGems Navigation menu

rubocop 1.56.2

RuboCop is a Ruby code style checking and code formatting tool. It aims to enforce the community-driven Ruby Style Guide.

Gemfile:
= Copy to clipboard Copied!

install:
=

Versions:

  1. 1.63.2 - April 16, 2024 (623 KB)
  2. 1.63.1 - April 10, 2024 (623 KB)
  3. 1.63.0 - April 08, 2024 (623 KB)
  4. 1.62.1 - March 11, 2024 (619 KB)
  5. 1.62.0 - March 06, 2024 (618 KB)
  6. 1.56.2 - August 29, 2023 (604 KB)
Show all versions (268 total)

Runtime Dependencies (11):

base64 ~> 0.1.1
json ~> 2.3
parallel ~> 1.10
parser >= 3.2.2.3
rainbow >= 2.2.2, < 4.0
regexp_parser >= 1.8, < 3.0
rexml >= 3.2.5, < 4.0
rubocop-ast >= 1.28.1, < 2.0
unicode-display_width >= 2.4.0, < 3.0

Owners:

Pushed by:

Authors:

  • Bozhidar Batsov, Jonas Arvidsson, Yuji Nakayama

SHA 256 checksum:

db35d1f59c293fc0f1262f6705e3d755929ebdba9de139903a880f8e6f7a28c3

Total downloads 410,703,122

For this version 1,206,710

License:

MIT

Required Ruby Version: >= 2.7.0

New versions require MFA: true

Version published with MFA: true

Links: