RubyGems Navigation menu

story_branch 2.3.0

This simple gem allows you to create a branch based on the existing issues in your preferred tracker. It integrates with PivotalTracker, Github and JIRA. Different workflows shall be supported in the next versions.

Gemfile:
= Copy to clipboard Copied!

install:
=

Versions:

  1. 2.3.0 - August 22, 2022 (27 KB)
  2. 2.2.1 - August 15, 2022 (26.5 KB)
  3. 2.2.0 - August 10, 2022 (26.5 KB)
  4. 2.1.0 - July 20, 2022 (24.5 KB)
  5. 2.0.1 - October 30, 2021 (24.5 KB)
Show all versions (45 total)

Runtime Dependencies (12):

blanket_wrapper ~> 3.0, > 3.0
damerau-levenshtein ~> 1.3, > 1.3
httparty > 0
jira-ruby > 1.7, < 3
thor > 0.20, < 2
tty-command ~> 0.8, > 0.8
tty-config ~> 0.2, > 0.2
tty-pager ~> 0.12, > 0.12
tty-prompt ~> 0.18, > 0.18
xdg > 3.0, < 6

Development Dependencies (10):

bundler ~> 2.1, > 2.1
fakefs > 0.14, < 2
git ~> 1.5, > 1.5
ostruct ~> 0.1, > 0.1
pry ~> 0.11, > 0.11
rake >= 12.3.3, < 14
rspec ~> 3, > 3
rspec_junit_formatter ~> 0.4, > 0.4
rubocop ~> 1.22
simplecov ~> 0.16, > 0.16

Owners:

Pushed by:

Authors:

  • Rui Baltazar, Jason Milkins, Dominic Wong, Ranhiru Cooray, Gabe Hollombe

SHA 256 checksum:

d4f1fc90e2d20365e57009c7c26c0c20eed937da72f78fe58d3b280ebe78c1d5

Total downloads 62,368

For this version 841

License:

MIT

Required Ruby Version: >= 2.4, < 3.1

Links: