RubyGems Navigation menu

dry-types 1.6.0

Type system for Ruby supporting coercions, constraints and complex types like structs, value objects, enums etc

Gemfile:
= 复制到剪贴板 已复制!

安装:
=

版本列表:

  1. 1.7.2 - January 05, 2024 (45.5 KB)
  2. 1.7.1 - February 17, 2023 (45.5 KB)
  3. 1.7.0 - November 04, 2022 (45.5 KB)
  4. 1.6.1 - October 15, 2022 (44.5 KB)
  5. 1.6.0 - October 15, 2022 (44.5 KB)
显示所有版本 (共 47 个)

Runtime 依赖 (6):

dry-container ~> 0.3
dry-core ~> 0.9, >= 0.9
dry-inflector ~> 0.1, >= 0.1.2
dry-logic ~> 1.3, >= 1.3
zeitwerk ~> 2.6

Development 依赖 (5):

bundler >= 0
dry-monads ~> 1.0
rake >= 0
rspec >= 0
yard >= 0

业主:

推送:

作者:

  • Piotr Solnica

SHA 256 校验和:

= 复制到剪贴板 已复制!

下载总量 113,831,904

这个版本 5,265

许可:

MIT

需要的 Ruby 版本: >= 2.7.0

链接: