RubyGems Navigation menu

dry-schema 1.4.0

dry-schema provides a DSL for defining schemas with keys and rules that should be applied to values. It supports coercion, input sanitization, custom types and localized error messages (with or without I18n gem). It's also used as the schema engine in dry-validation.

Gemfile:
= Copier Copié!

installation:
=

Versions:

  1. 1.13.4 - May 22, 2024 (45 ko)
  2. 1.13.3 - August 26, 2023 (45 ko)
  3. 1.13.2 - May 31, 2023 (45 ko)
  4. 1.13.1 - April 07, 2023 (45 ko)
  5. 1.13.0 - November 24, 2022 (45 ko)
  6. 1.4.0 - October 08, 2019 (33,5 ko)
Voir toutes les versions (57)

Dépendances de Runtime (7):

dry-configurable ~> 0.8, >= 0.8.3
dry-core ~> 0.4
dry-equalizer ~> 0.2
dry-logic ~> 1.0
dry-types ~> 1.2

Dépendances de Development (3):

bundler >= 0
rake >= 0
rspec >= 0

Propriétaires:

Pushed by:

Auteurs:

  • Piotr Solnica

Total de contrôle SHA 256:

= Copier Copié!

Total de téléchargements 53 089 517

Pour cette version 4 229

License:

MIT

Version de Ruby requise: >= 2.4

Liens: